Problem with downloading Look and Feel Themes from within KDE System Settings with Frameworks 5.58

Edited by admin:
There is a known upstream bug in KDE Frameworks, that made the KDE Team develop a 5.58.2 hotfix that is pending release. Please look when it is available for your distro of choice.

I’m trying to get through the System Settings, install Look and Feel Theme, but that’s not possible. I also tried with ocs-url, but without success.
Is that a problem for me, or …?

Thanks in advance,

I have a similar problem with arch, for my part it comes from frameworkintegration 5.58.1-1.
I have downgrade to frameworkintegration-5.57.0-1 and now it’s ok

There is a discussion here with a bugtracker link but there are not many people who say they have the problem so I do not know if it’s generalized


I tried in VirtualBox, where I have installed openSUSE Tumbleweed (Krypton).
KDE Frameworks Version: 5.59.0 and everything is fine

So the problem is in KDE Frameworks 5.58.

Hi l4k1,

yes, there is a known upstream bug in KDE Frameworks, which made the KDE Team do a 5.58.1 hotfix release according to our knowledge.


Thank you for your prompt reply!

Thank you, @l4k1 , for highlighting the bug and not just keeping it to yourself. I am currently trying to solve an open issue on my repository and this could be, with a high probability, the cause of the problem. If it wasn’t for you I would probably have spent a lot of time trying to find a cause for the issue!

The bug is in the package frameworkintegration.
A fix was done that resulted in the 5.58.1 version tough turned out wasn’t correct, hopefully a 5.58.2 that actually fixes it sould come out shortly

1 Like