Broken zip archive

Hello! I’m facing strange issue. I have uploaded various Rom’s and all of them were working correctly after downloading them but after 2 days people started to complain that Zips can’t be flashed, it shows that they are corrupted. I reuploaded roms again and everything worked, but today problem happened again, one of the zips became corrupted. Can i get explanation why zips became corrupted after some time?
Here is the file:
OP6 - HydrogenOS


thanks for reporting the issue.
We will try to find out why people could be experiencing such an issues.
Do you have the correct md5 hash sum, so anyone can compare the original with whatever was downloaded?

Yes, i have it but many users have limited data and they will need to download file first and only then check it. So it is problematic.

Yes, sure, but what is the md5 hash sum for above file?


I downloaded the ZIP, and it has the following md5 sum:

this is how it looks extracted:

Can you doublecheck the md5sum of the ZIP is correct?

The file size downloaded here is also exactly like on the server:

So what is your exact filesize of the zip on your local machine before you upload it?

Here are screenshots. You can see it is same as the one i sent yesterday.

Btw, one more zip got corrupted yesterday. First ~20 downloads were ok, but then i started to get messages from users about zip is corrupted
OP5T - HydrogenOS
its md5sum is f64ca441ebc869220d2edf62b9e218e1

If the first downloads were okay, it seems very unlikely the file on the server got corrupted.
We will investigate further why this never happened with other files before, it is most likely got to do with the >1.0+GB filesize.

Can you upload this or another, similarly big file again on a new product and immediately let us know here, so we can check the md5sum?

Meanwhile, we have uploaded the initial file you posted to the server again, and the md5 stayed the same. That is when we downloaded it from the server, it had the same hash than on the server and now after reuploading the same file to another product, it also has the same hash on the server again:

OP6 - HydrogenOS

So when someone downloads this file, it should also have md5sum of the above.
That means during our cycle with uploading a big file like yours the hash stayed consistent so far here local and on server.

We will keep an eye on the file if anything happens with it, like in case ot would change the md5sum in 1 hour or 24 hours.
If this stays stable, then we assume that the issue lies in uploading the file, since it seems to have ended on the server with a different hashsum than what you have local.

What browser or method do you use to upload the file?

I’m sorry! I was away. I’m uploading files through Brave browser on windows 10.

This md5 is already corrupted. I think new working file should be uploaded. If it is needed i will do it.
Want to remind that first downloads were Ok. I uploaded file for testers and they could flash but day after when i shared with all users problem appeared.

I uploaded new file
OP7Pro -
its md5 545e1dd97cde99697c9556be9d73b684

Hi annalerias,

the hash on the server for your latest file is different again.

Now to find out what is really going on, we want you to download and reupload some file to a test product (please use a new product and label it clearly “Test” or such, so we can compare things), where we know the hash on the server (regardless if its wrong or not):

Please download this ZIP, let us know the hashsum of what you downloaded and Reupload it to a new TEST PRODUCT. Do NOT use your old local file of the same name.
Thank you.

Hello! Ok, will do it right now.

Thanks for helping to find out what might be the cause for the issues on your side.

Product created and file uploaded
OP6 - HydrogenOS

Thanks. What does your local md5sum say for this file?


Great, thanks.
So now the file you downloaded from server had the same hash, which means it got downloaded correctly, then uploaded again correctly to a new file, then confirmed that this file on server also still has the same hash as above.
So the whole chain has worked once, now we will watch if file ever changes over time.

Can you remember if you did anything after uploading your files once, like change version numbers, change text, etc.?

only added name of rom in “version” gap